Archives pour la catégorie Tout

NAGIOS

Nagios est une application ( Libre , licence GPL ) qui permet la supervision ( surveillance ) d’un système et réseau. On programme le serveur pour qu’il nous envoi l’état des hôtes ou de service spécifique . La modulation de cette application est un atout . On peut obtenir les plus petits détails ( Température , RAM , % CPU , occupation du disque dur .. d’un switch ou même nous indiquer la version d’un routeur toute les 5 secondes..)

On peut trouver toutes ses caractéristiques grâce à l’ OID ( identifiants universel )

Nagios se compose en 3 parties :

  • Le moteur de l’application pour les tâches de supervision
  • L’interface web pour la vue d’ensemble https://www.novell.com/coolsolutions/img/nagios_html_2f522541.png
  • Les plugins sont les mini-programmes qui exécutent nos tâches

Une autre application dans le même genre : CENTREON

La différence est  d’un côté on a un  prêt à l’emploi (Centreon) et de l’autre le sur-mesure (Nagios + plugins + addons).

Avantages :

  • Créer ses propres plugins, dans le langage désiré. Il suffit de respecter la norme Nagios des Codes retour
    • 0 OK (tout va bien)
    • 1 WARNING (le seuil d’alerte est dépassé)
    • 2 CRITICAL (le service a un problème)
    • 3 UNKNOWN (impossible de connaître l’état du service)
  • Hiérarchie dans le réseau
  • Plus flexible
  • Moins d’ automatisation , retour sur les fondamentaux et de la compréhension sur la complexité à la programmation en supervision

Inconvénients:

  • Complexité d’utilisation ( Certains autres serveurs de supervision sont plus simple)
  • Beaucoup de demande de la communauté sur des améliorations
  • Architecture des modèles de programmation trop tolérante et la difficulté de certaines d’entre eux

 

Serveur Base de donnée

Un serveur de base de donnée sert à stockée , extraire et gérer une base de donnée. On a recoure au langage SQL.

Voici un exemple d’une  petite base de données :

Il contient des élèves , des moniteurs , voitures et les leçons

Par exemple , Un élève à une heure de conduite avec x moniteur , x voiture et date/ heure de la leçon.

Afficher l'image d'origine

Sa permet a une auto-école de gérer ses rendez-vous , de voir s’il reste des place de libre ou même qu’elle moniteur à eu tel voiture à cette heure la. Combien d’heure de conduite à fait un élève. ..

Mais aussi pour le E-commerces: Avec une gestions des stocks, des avantages données à certains client..

Le serveur sert d’hébergeur pour un site web .Presque tout les sites web se servent d’une base de données ( le fil d’actualité de facebook , résultat de recherche sur google, les petites annonces.. )

http://www.marginweb.com/blog/20121110/quand-et-pourquoi-utiliser-une-base-de-donnees-nosql

 

 

 

 

DNS

DNS = Domain Name Server

Un serveur DNS est un service permettant de traduire un nom domaine en information. Un nom de domaine est un identifiant sur Internet.  On peut le trouver de 2 façon :

Un nom de domaine : www.google.fr

Une adresse IP : 172.217.17.227

C’est l’une des adresse utilisé par google. Un nom de domaine peut être associé à plusieurs adresses.

Le rôle du DNS : Chaque ordinateur à une adresse IP comme identifiant. Une adresse IP est une suite de 0 et de 1 ( base binaire ) sur 8 bits.  Sa devient alors compliqué de se souvenir par coeur de chaque adresse , on a décidé de donner un nom pour une adresse pour y accéder plus facilement. C’est le DNS.

Résoudre un nom de domaine consiste à trouver l’adresse IP qui lui est associée.

de = la langue utilisé

wikipedia.org = le nom de domaine

Tous les ordinateurs connecter à internet passe par un serveur DNS pour communiquer

Avantages :

  • Son avantage principal est en même temps sa fonction principal ou nous n’avons pas à taper l’adresse IP d’un site web pour y accéder
  • Possibilité d’avoir un cache DNS ( avec des sites web déjà répertorié )pour aller plus vite

Inconvénients:

  • En cas de grand réseau , prévoir un 2e serveur DNS pour la redondance, si le principal tombe en panne   , le secondaire le remplace !

La Virtualisation (XEN , VMWARE )

La virtualisation consiste à faire fonctionner un ou plusieurs systèmes d’exploitation/ applications comme un simple logiciel, sur un ou plusieurs ordinateurs – serveurs / système d’exploitation, au lieu de ne pouvoir en installer qu’un seul par machine.

Les systèmes d’exploitation invités partagent ainsi les ressources de la machine hôte.

Xen est un logiciel libre de virtualisation, plus précisément un hyperviseur de machine virtuelle.

Exemple d’un XEN :

Afficher l'image d'origine

WMware est une société informatique en virtualisation.

Afficher l'image d'origine

Ils ont créer plusieurs type de virtualisation :

  • VMware Workstation : Permet la création de plusieurs machine virtuelle au sein d’un même système d’exploitation. Il a l’avantage d’être directement connecter au même réseau que l’ordinateur.Mais ne peut pas utiliser les performances de la machine à 100 % . Il avant tout dédié au système installé de base

 

  • VmWare EXS : (HyperViseur ) Le produit s’installe sur la couche matériel et non sur un OS. Il permet un fonctionnement plus précis des ressources donc de meilleure performances . La gestion des serveurs se fait soit par naviguateur soit par un outil de gestion ( Vsphere client )

XEN et VmWare EXS sont tout les 2 des hyper Viseur opensource.

Avantages et Inconvénients:

la fiabilité, la haute dispo, la migration à chaud , la capacité d’évolution,les performances des produits, la gestion des drivers, la compatibilité avec les OS . Mais pas vraiment de différence fondamental.

 

 

 

Point d’accès wifi

Un point d’accès wifi est un appareil qui permet de relier plusieurs appareils informatiques sans fil(ordinateur, routeur, smartphone, décodeur Internet, etc.) au sein d’un réseau informatique afin de permettre la transmission de données entre eux.

Nos modems (LiveBox,SFRbox..)  ont la fonction points d’accès wifi.

Afficher l'image d'origine

 

A la différence d’un AP ( Access Point ou Point d’accès )Il faut une carte wifi pour se connecter.

Le SSID ( Service Set Identifier ) sur un réseau sans fil est le nom que l’on voit lors de la recherche de wifi . (Ex: Livebox-B5E6)

Avantages :

  • Plus besoin de câble , on peut se connecter dans toute une maison ( distance moyenne : 20 m, Aussi bien en hauteur qu’en longueur )
  • Différents type de sécurité : Filtrage MAC ,  Possibilité de cacher le SSID, Clé WPA/WEP ( mot de passe) , portail captif (login + mot de passe )

Désavantage :

  • Perte potentiel de débit ( Perturbation électromagnétique   ( On est sur du sans fil comme même )
  • On ouvre une porte vers notre réseau ( Surtout si on ajoute pas + de sécurité )
  • Ajoute du travail à l’administrateur ( Positionnement des points d’accès, éviter les perturbations , configuration )
  • Disponibilité non garantie à 100%

Administration de Switch 2960/3750g

Cisco 2960

Afficher l'image d'origine

Cisco 3750Afficher l'image d'origine

voici une liste de commande sur un switch Cisco:

Afficher la configuration active

  • Switch#write terminal
  • Switch#show running-config

Afficher l’heure puis la changer

  • Switchig1>clock
  • Switch#clock set
  • hh:mm:ss Current Time jour (chiffres) mois(3lettres) année (4chiffres)

Sauvegarder sur un serveur TFTP la configuration en mémoire

  • Swbtsig1#copy running-config tftp
  • Ip du serveur tftp :
  • Nom du fichier de sauvegarde :

Passer en mode super-utilisateur

  • switch>enable
  • switch#

Changer le nom de votre switch

  • Switch#conf t
  • Switch#conf terminal
  • Enter configuration commands, one per line.  End with CNTL/Z.
  • Switch(config)#hostname vlanswitch
  • vlanswitch(config)#

Création de VLAN sur les switchs  

  • Création du vlan n° 2 ayant comme nom vlan_2
  • vlanswitch>enable
  • vlanswitch#conf t
  • vlanswitch(config)#vlan 2
  • vlanswitch(config-vlan)#name vlan_2
  • vlanswitch(config-vlan)#exit

Affichage des vlans

  • vlanswitch#show vlan

Affectation des ports aux vlans

  • Dans une configuration de VLAN statique, les ports du commutateur doivent être attribués à un Vlan
  • switchvlan(config)#interface f0/2
  • switchvlan(config-if)#switchport mode access
  • switchvlan(config-if)#switchport access vlan 2
  • attribution du vlan spécifié à l’interface

Affectation d’une IP a un VLAN

  • Switch(config)#interface vlan 1
  • Switch(config-if)#ip address 192.168.1.254 255.255.255.0
  • Switch(config-if)#no shutdown
  • Switch(config-if)#
  • Switch(config-if)#exit

Création d’un lien Trunk permettant le transport des vlans

  • Configurer le port 22 du switch pour qu’il transporte les vlans (mode trunk)
  • switchvlan#conf t
  • switchvlan(config)#interface fa0/22
  • switchvlan(config-if)#switchport mode trunk
  • switchvlan(config-if)#switchport trunk allowed vlan all (autorise tout les vlans)
  • switchvlan(config-if)#exit

Supprimer un vlan

  • switchvlan(config)#no vlan 2

Passer en mode privilège

  • Switch> enable
  • Switch#

Les mots de passe

  • Switch(config)#enable secret arle
  • Switch(config)#line console 0
  • Switch(config-line)#login
  • Switch(config-line) #password arle
  • Swith(config)#username btsig privilege 15 password arle
  • Switch(config)#line vty 0 4
  • Switch(config-line)#] privilege level 15
  • Switch(config-line)#password line
  • Switch(config-line)# transport input telnet