DNS

DNS = Domain Name Server

Un serveur DNS est un service permettant de traduire un nom domaine en information. Un nom de domaine est un identifiant sur Internet.  On peut le trouver de 2 façon :

Un nom de domaine : www.google.fr

Une adresse IP : 172.217.17.227

C’est l’une des adresse utilisé par google. Un nom de domaine peut être associé à plusieurs adresses.

Le rôle du DNS : Chaque ordinateur à une adresse IP comme identifiant. Une adresse IP est une suite de 0 et de 1 ( base binaire ) sur 8 bits.  Sa devient alors compliqué de se souvenir par coeur de chaque adresse , on a décidé de donner un nom pour une adresse pour y accéder plus facilement. C’est le DNS.

Résoudre un nom de domaine consiste à trouver l’adresse IP qui lui est associée.

de = la langue utilisé

wikipedia.org = le nom de domaine

Tous les ordinateurs connecter à internet passe par un serveur DNS pour communiquer

Avantages :

  • Son avantage principal est en même temps sa fonction principal ou nous n’avons pas à taper l’adresse IP d’un site web pour y accéder
  • Possibilité d’avoir un cache DNS ( avec des sites web déjà répertorié )pour aller plus vite

Inconvénients:

  • En cas de grand réseau , prévoir un 2e serveur DNS pour la redondance, si le principal tombe en panne   , le secondaire le remplace !

La Virtualisation (XEN , VMWARE )

La virtualisation consiste à faire fonctionner un ou plusieurs systèmes d’exploitation/ applications comme un simple logiciel, sur un ou plusieurs ordinateurs – serveurs / système d’exploitation, au lieu de ne pouvoir en installer qu’un seul par machine.

Les systèmes d’exploitation invités partagent ainsi les ressources de la machine hôte.

Xen est un logiciel libre de virtualisation, plus précisément un hyperviseur de machine virtuelle.

Exemple d’un XEN :

Afficher l'image d'origine

WMware est une société informatique en virtualisation.

Afficher l'image d'origine

Ils ont créer plusieurs type de virtualisation :

  • VMware Workstation : Permet la création de plusieurs machine virtuelle au sein d’un même système d’exploitation. Il a l’avantage d’être directement connecter au même réseau que l’ordinateur.Mais ne peut pas utiliser les performances de la machine à 100 % . Il avant tout dédié au système installé de base

 

  • VmWare EXS : (HyperViseur ) Le produit s’installe sur la couche matériel et non sur un OS. Il permet un fonctionnement plus précis des ressources donc de meilleure performances . La gestion des serveurs se fait soit par naviguateur soit par un outil de gestion ( Vsphere client )

XEN et VmWare EXS sont tout les 2 des hyper Viseur opensource.

Avantages et Inconvénients:

la fiabilité, la haute dispo, la migration à chaud , la capacité d’évolution,les performances des produits, la gestion des drivers, la compatibilité avec les OS . Mais pas vraiment de différence fondamental.

 

 

 

Point d’accès wifi

Un point d’accès wifi est un appareil qui permet de relier plusieurs appareils informatiques sans fil(ordinateur, routeur, smartphone, décodeur Internet, etc.) au sein d’un réseau informatique afin de permettre la transmission de données entre eux.

Nos modems (LiveBox,SFRbox..)  ont la fonction points d’accès wifi.

Afficher l'image d'origine

 

A la différence d’un AP ( Access Point ou Point d’accès )Il faut une carte wifi pour se connecter.

Le SSID ( Service Set Identifier ) sur un réseau sans fil est le nom que l’on voit lors de la recherche de wifi . (Ex: Livebox-B5E6)

Avantages :

  • Plus besoin de câble , on peut se connecter dans toute une maison ( distance moyenne : 20 m, Aussi bien en hauteur qu’en longueur )
  • Différents type de sécurité : Filtrage MAC ,  Possibilité de cacher le SSID, Clé WPA/WEP ( mot de passe) , portail captif (login + mot de passe )

Désavantage :

  • Perte potentiel de débit ( Perturbation électromagnétique   ( On est sur du sans fil comme même )
  • On ouvre une porte vers notre réseau ( Surtout si on ajoute pas + de sécurité )
  • Ajoute du travail à l’administrateur ( Positionnement des points d’accès, éviter les perturbations , configuration )
  • Disponibilité non garantie à 100%

Administration de Switch 2960/3750g

Cisco 2960

Afficher l'image d'origine

Cisco 3750Afficher l'image d'origine

voici une liste de commande sur un switch Cisco:

Afficher la configuration active

  • Switch#write terminal
  • Switch#show running-config

Afficher l’heure puis la changer

  • Switchig1>clock
  • Switch#clock set
  • hh:mm:ss Current Time jour (chiffres) mois(3lettres) année (4chiffres)

Sauvegarder sur un serveur TFTP la configuration en mémoire

  • Swbtsig1#copy running-config tftp
  • Ip du serveur tftp :
  • Nom du fichier de sauvegarde :

Passer en mode super-utilisateur

  • switch>enable
  • switch#

Changer le nom de votre switch

  • Switch#conf t
  • Switch#conf terminal
  • Enter configuration commands, one per line.  End with CNTL/Z.
  • Switch(config)#hostname vlanswitch
  • vlanswitch(config)#

Création de VLAN sur les switchs  

  • Création du vlan n° 2 ayant comme nom vlan_2
  • vlanswitch>enable
  • vlanswitch#conf t
  • vlanswitch(config)#vlan 2
  • vlanswitch(config-vlan)#name vlan_2
  • vlanswitch(config-vlan)#exit

Affichage des vlans

  • vlanswitch#show vlan

Affectation des ports aux vlans

  • Dans une configuration de VLAN statique, les ports du commutateur doivent être attribués à un Vlan
  • switchvlan(config)#interface f0/2
  • switchvlan(config-if)#switchport mode access
  • switchvlan(config-if)#switchport access vlan 2
  • attribution du vlan spécifié à l’interface

Affectation d’une IP a un VLAN

  • Switch(config)#interface vlan 1
  • Switch(config-if)#ip address 192.168.1.254 255.255.255.0
  • Switch(config-if)#no shutdown
  • Switch(config-if)#
  • Switch(config-if)#exit

Création d’un lien Trunk permettant le transport des vlans

  • Configurer le port 22 du switch pour qu’il transporte les vlans (mode trunk)
  • switchvlan#conf t
  • switchvlan(config)#interface fa0/22
  • switchvlan(config-if)#switchport mode trunk
  • switchvlan(config-if)#switchport trunk allowed vlan all (autorise tout les vlans)
  • switchvlan(config-if)#exit

Supprimer un vlan

  • switchvlan(config)#no vlan 2

Passer en mode privilège

  • Switch> enable
  • Switch#

Les mots de passe

  • Switch(config)#enable secret arle
  • Switch(config)#line console 0
  • Switch(config-line)#login
  • Switch(config-line) #password arle
  • Swith(config)#username btsig privilege 15 password arle
  • Switch(config)#line vty 0 4
  • Switch(config-line)#] privilege level 15
  • Switch(config-line)#password line
  • Switch(config-line)# transport input telnet

GLPI

Afficher l'image d'origine

GLPI = Gestion libre de parc informatique

C’est un logiciel , open source,  de gestion des services informatiques et d’assistance . Dans un lycée , par exemple , plusieurs salles de classes ont des ordinateurs d’installés avec des imprimante, il y a des salles serveurs , plusieurs arrivé d’internet , point d’accès wifi.. . GLPI permet de gérer l’ensemble du matériel. En cas de panne ou de casse, l’utilisateur est amené à envoyer un « ticket »( avec des informations sur le numéro de pc et de la salle ) via GLPI pour indiquer le problème survenu. L’administrateur  peut alors très vite intervenir .

Afficher l'image d'origine

On peut y ajouter toutes sortes d’informations (le matériel du pc , date update.. ) S’il faut remplacer un disque dur ancien, processeur..

Avantages:

  • Gratuit , Open source , on a le droit d’exécution , de modification et de développement qui permet de la part de contributeurs de faire évoluer le logiciel en y ajoutant des modules complémentaires.
  • Parfait pour de grandes structure ( d’une centaine à des milliers  !)
  • Énormément d’avantages si il est couplé de OCS inventory )

Désavantages :

  • Le logiciel à un énorme potentiel mais il nécessite des compétences approfondi de la chose.
  • GLPI est utilisé par des « sociétés publiques  » ou collectivité mais pas de grands groupe privée.

 

PHP

PHP ( HyperText Preprocessor ) est un langage de script généraliste et open source fait pour le langage web ( s’intégre à l’HTML)

Le PHP est un langage côté serveur alors que le Javascript ( langage web ) est un langage côté client. Le client ne reçois que le résultat , il ne voit pas le code écritphp

On peut voir un code HTML et au milieu avec « <?php » la balise indiquant le début du PHP directement intégré dans le code

Avantage :

  • Assez simple pour les débutants mais offre des fonctionnalité avancé pour les experts
  • Des outils présents de base qui rend le PHP incomparable au C (ne serait que la classe DateTime
  • Couplé à un framework + MVC, on arrive à de très bonnes structures.
  • Présent chez de très nombreux hébergeurs.
  • Le temps de développement est diminué par rapport à bon nombre de langages.

Inconvénients:

  • Le langage n’est pas normé , il n’y a aucune base . Chaque fonction à été bricolé au petit bonheur.
  • Aucun typage des variables, c’est très pénible pour la documentation et les contrôles des fonctions/méthodes.
  • Des noms de fonctions par cohérents (lacunes du passé)
  • Nécessite l’activation de caches PHP si on veut parler un minimum de performances (normal, la compilation des sources à chaque page ou presque est un processus couteux
  • Gestion de l’unicode un peu foireuse (expérience personnelle avec l’UTF-8 + BOM)

 

 

 

Pascal

Le Pascal est un langage de programmation impératif (opère par des  séquences d’instructions exécutées par l’ordinateur en modifiant l’état du programme ) qui à été créer dans un but éducatif.

Il se rapproche énormément du langage C et se caractérise par une syntaxe clair et rigoureuse .

On utilise le pascal avec l’application Delphi ( Free Pascal ou plein d’autre version  )

Afficher l'image d'origine

le programme est un assemblage de procédures et de fonctions, dans lesquelles on peut utiliser des blocs conditionnels (if, case) et répétitifs (while, for, repeat) avec un début et une fin.

Avantage :

  • Langage typé ( toutes les variables doivent avoir un type défini au moment de la compilation)
  • Permet de retrouver ses erreurs facilements
  • Rigueur de la syntaxe

Inconvénient:

  • Les passages du type caractère au type chaîne de caractères manque de souplesse
  • Aucune UPDATE  depuis 1993

HTML

HTML = Hypertext Markup Language

C’est le langage utilisé pour le représenter les pages Web. Créer en 1989 , a connu beaucoup de changement depuis HTML 1 à sa dernière version HTML 5.

Permet de mettre en forme le contenu des pages, d’inclure des ressources multimédias dont des images, des formulaires de saisie, et des programmes informatiques.

Afficher l'image d'origine

Le langage est formé de balise pour communiquer en hypertexte ( Un document avec des « unités d’informations » liées entre elles par des hyperliens, pour accéder directement à l’information )

Avantages :

  • Indépendant , on peut ouvrir un fichier html avec n’importe quel éditeur de texte.
  • Conçu par des usagers , pour des usagers
  • L’hypertexte permet de gérer des informations très diversifiées sans devoir les stocker localement.

Désavantages:

  • Le stockage d’une page représente en général plusieurs fichiers. (voir beaucoup pour une seul page)
  • La mise en forme est limité et parfois complexes à mettre en oeuvre (Frames).
  • Utilisation destinée (quasiment) seulement à Internet principalement

 

Le HTML est utilisé en parallèle avec le Javascript ( langage de programmation de scripts  employé dans les pages web interactives ) et par le CSS (langage informatique qui décrit la présentation des documents HTML et XML )

 

DHCP

DHCP = Dynamic Host Configuration Protocol

C’est un protocole  qui permet à un client d’obtenir des informations Réseaux  ( Adresse IP , Masque de sous réseau , Passerelle , DNS, Routage ) de manière automatique et dynamique.

Dynamique signifie que l’adressage donné change suivant un bail. ( Ex: Toutes les 24h un pc aura une nouvelle adresse IP pour une question de sécurité )

Les avantages : Permet de configuré un parc informatique  de façon automatique. Gain de temps

Les Inconvénients : Si le serveur DHCP plante , tous les pc perdent leur configuration réseau ( Très gênant dans de grande entreprise ).
On doit comme même avoir des adresse IP en fix ( Imprimantes , autre serveur .. )

Autre option avec le DHCP:

DHCP snooping : ( Snooping = espionnage ) Une technique mis en place pour contrer les hackers. Le pirate se connecte sur le réseau est installe son propre DHCP pour rendre l’autre inutilisable. A partir de là , il peut faire ce qu’il veut. La méthode pour contrer cette attaque est d’associer un « port de confiance  » au switch. On indique au switch par qu’elle port les  requêtes DHCP  doivent passer. Les requêtes du DHCP pirate sont alors ignorer par le switch.

DHCP Relais : Permet à un serveur DHCP de passer à travers un routeur pour gérer un autre réseau. On passe la commande « ip-helper xxxx.xxxx.xxxx.xxxx » sur l’interface inside du routeur.

Les trames DHCP:

Lorsqu’on passe un PC en automatique , voici les 4 échanges qu’ils se passent entre eux.

Discover : Le client cherche un serveur DHCP

Offer: Le DHCP lui répond, est indique où il est.

Request: Le client envoi sa requête DHCP

Ack: Le serveur lui assigne des paramètres ip.

dhcp